WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#27004 closed defect (bug) (duplicate)

WP_Image_Editor_GD breaks onload caused by memory_limit

Reported by: tricd Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8.1
Component: Media Keywords:
Focuses: Cc:

Description

When using the Image_Editor_GB load function, the function imagecreatefromstring will be called - with an @-sign.

This function can easily cause an memory-limit-exception when handling big images. The function will break asap and the next check is_resource is not even called.

In the first place it would be great, to at least remove the @ sign, so that someone can find out which function caused the problem. I searched for 4 hrs now.

Change History (3)

#1 @SergeyBiryukov
6 years ago

#27004 was marked as a duplicate.

Last edited 6 years ago by SergeyBiryukov (previous) (diff)

#2 @SergeyBiryukov
6 years ago

#27004 was marked as a duplicate.

Last edited 6 years ago by SergeyBiryukov (previous) (diff)

#3 @SergeyBiryukov
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #23127.

Note: See TracTickets for help on using tickets.