WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#27010 closed defect (bug) (duplicate)

Editing a term updates all terms with the same name or slug, regardless of what taxonomy it is in.

Reported by: desrosj Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8.1
Component: Taxonomy Keywords:
Focuses: Cc:

Description

Steps to reproduce.

  1. Fresh WordPress install.
  2. Add a post category.
  3. Add a post tag with the same title.
  4. Edit the post category title.
  5. Notice the post tag title also changed.

This also happens when editing the post slug. Does not matter if taxonomies are hierarchical/non-hierarchical. Also renames terms in custom taxonomies. Editing a term's parent does not change other term parents. Only specific to name and slug.

Change History (1)

#1 @helen
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #5809.

Note: See TracTickets for help on using tickets.