WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#27035 closed defect (bug) (invalid)

Media Selection /Upload Not Responsive on 4.7 Inch Screen

Reported by: DennisBarkerCV Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8.1
Component: Media Keywords:
Focuses: ui Cc:
PR Number:

Description

I use an HTC One X with a 4.7 inch screen for some of my admin and find it difficult to add media to a post. The media selectiom/upload screen is not responsive to this screen size and this makes media attachment tricky.

Attachments (1)

Screenshot_2014-07-12-18-31-05.png (171.3 KB) - added by DennisBarkerCV 6 years ago.
Media List in Firefox on HTC One X

Download all attachments as: .zip

Change History (13)

#1 follow-up: @helen
6 years ago

  • Focuses accessibility administration removed

Hi DennisBarkerCV - thanks for the report. The media modal is responsive and accommodates even smaller screen sizes, although to be sure it was not designed with them in mind originally and so is not necessarily ideal. Could you be a little more specific about what it is that you find tricky, and if possible, upload a screenshot or picture of what it looks like on your device?

#2 @helen
6 years ago

  • Keywords reporter-feedback added

#3 in reply to: ↑ 1 @DennisBarkerCV
6 years ago

Replying to helen:

Hi DennisBarkerCV - thanks for the report. The media modal is responsive and accommodates even smaller screen sizes, although to be sure it was not designed with them in mind originally and so is not necessarily ideal. Could you be a little more specific about what it is that you find tricky, and if possible, upload a screenshot or picture of what it looks like on your device?

The main issue I found is that when uploading or selecting from the media library. an image in portrait mode the images are small and the two column layout has a lot of white space in the right side.

Landscape mode seems ok,but portrait mode creates an issue with touch responsiveness which limits the number of images available for selection.

#4 @ericlewis
6 years ago

  • Keywords ui-feedback needs-patch added; reporter-feedback removed

#5 @ericlewis
6 years ago

  • Keywords needs-patch removed

#6 @ocean90
6 years ago

DennisBarkerCV, can you attach some screenshots please?

@DennisBarkerCV
6 years ago

Media List in Firefox on HTC One X

#7 @ocean90
6 years ago

  • Keywords close added; ui-feedback removed

Thanks for the screenshot. That's the old media modal, which is deprecated. Is that from a plugin which you're using?

#8 @DennisBarkerCV
6 years ago

I don't have any plugins running that would specifically effect that screen.

#9 follow-up: @ocean90
6 years ago

You're still running WP 3.8.1? Or where are you seeing this?

#10 in reply to: ↑ 9 @DennisBarkerCV
6 years ago

Replying to ocean90:

You're still running WP 3.8.1? Or where are you seeing this?

I'm running 3.9.1 and the issue is when adding a featured image to a new post and using the insert media link from the post screen.

#12 @ocean90
6 years ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

#27423 is the future.

Note: See TracTickets for help on using tickets.