WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#27040 closed defect (bug) (invalid)

Enter Distraction Free Mode Key Shortcut overrides normal Operating System behaviour on OSX

Reported by: clov3rly Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9
Component: Editor Keywords: reporter-feedback
Focuses: administration Cc:

Description

In OSX, option-left and option-right move between words in a body of text. I personally use them a lot. The new distraction free mode keyboard shortcut overrides the option-right shortcut, and throws me off every time I use it.

If someone can point me to the code where I can override this shortcut, that would be sweet, but I thought I should submit this bug report, as this feature overrides core browser and OS behaviour. Which is generally a no-no.

Thanks.

Change History (4)

#1 @TobiasBg
5 years ago

  • Focuses administration added
  • Keywords reporter-feedback added

The default keyboard shortcut for opening the "Distraction Free Writing" mode on Mac is "Option+Shift+W", which works fine for me both in WordPress 3.8.1 and in trunk (using Chrome on OS X).
"Option-Left" and "Option-Right" move the cursor before/after the next word, as expected.

What's happening for you when you press "Option+Shift+W"?
Where did you get a "new distraction free mode keyboard shortcut" from? And what is that new shortcut for you?
Can you reproduce this with all plugins deactivated and after switching to a WordPress default theme?

#2 @DrewAPicture
5 years ago

Also can't reproduce on latest Firefox nor latest Safari.

#3 @clov3rly
5 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Please ignore me, I'm a muppet. KeyRemapforMacBook was doing weird things.

#4 @TobiasBg
5 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.