WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#27061 closed defect (bug) (fixed)

Twenty Eleven: Previous/Next links don't work in mobile

Reported by: blankthemes Owned by: lancewillett
Milestone: 3.9 Priority: normal
Severity: normal Version: 3.2
Component: Bundled Theme Keywords: has-patch
Focuses: Cc:

Description

The Next and Previous links at the top are not clickable on small devices.

Attachments (2)

6506.diff (327 bytes) - added by blankthemes 8 years ago.
27061.diff (793 bytes) - added by lancewillett 8 years ago.

Download all attachments as: .zip

Change History (7)

@blankthemes
8 years ago

#1 @blankthemes
8 years ago

The attached .diff fixes the issue for links not being able to click on single posts.

#2 @ericlewis
8 years ago

  • Keywords reporter-feedback added
  • Version set to 3.2

I can't reproduce this, in Chrome on iPhone 4S.

@blankthemes can you give more detail about reproducing this bug? what device you found it on? also, can you confirm this was on a vanilla install of twenty eleven with no plugins installed?

#3 @SergeyBiryukov
8 years ago

Related: #18884

I can reproduce in Firefox 27 and Chrome 33 at the width of 190px or less. The patch fixes it for me.

#4 @lancewillett
8 years ago

  • Keywords has-patch added; reporter-feedback removed
  • Milestone changed from Awaiting Review to 3.9

Clarification after testing a bit more in various devices, works fine in iOS and Android but is broken in Windows Phone or when you use a desktop browser and just resize down.

A better fix is moving the .singular .entry-header .entry-meta rule to the correct media query block to cover all small screen cases.

@lancewillett
8 years ago

#5 @lancewillett
8 years ago

  • Owner set to lancewillett
  • Resolution set to fixed
  • Status changed from new to closed

In 27570:

Twenty Eleven: make sure top post meta output isn't broken on small screens. Fixes #27061.

Note: See TracTickets for help on using tickets.