WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#27146 closed defect (bug) (duplicate)

All feeds return 404 error if no posts available

Reported by: jokr Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8.1
Component: Feeds Keywords:
Focuses: Cc:

Description

Under the current version of WordPress core (3.8.1) all feeds of a blog return 404 status code if there is no post published on this blog (depending on the client, the content of the feed might still be shown).

While somewhat okay for the standard feeds, this includes custom feeds which might display any other content which is not related to the posts. Thus, I believe this behavior is unwanted and hinders some plugin development.

Change History (1)

#1 @SergeyBiryukov
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #18505.

Note: See TracTickets for help on using tickets.