WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 years ago

#27164 closed defect (bug) (duplicate)

Automatic updates of localized versions

Reported by: pavelevap Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8.1
Component: Upgrade/Install Keywords:
Focuses: Cc:

Description

Automatic updates works well for English version, but there are some problems for localized versions.

As soon as 3.8.1 was released, all installations (including localized) were automatically updated to original English version. And translators have two wrong options:

  • Release localized package for 3.8.1. But in this case there will be yellow message displayed to inform about new update. So, users have to update once again to latest localized version through Dashboard - Updates menu. Can we have also automatic updates for localized versions? Only changed source files + language files and not the whole package?
  • Do not release localized package for 3.8.1 to not bothering users with update message. But this solution is problem for users updating from 3.7.x (and older), because they will not get latest language files (but only English version).

Change History (7)

#1 @ocean90
7 years ago

  • Milestone changed from Awaiting Review to Future Release

The plan is to get rid of localized packages. I thought we already have a ticket for this, seems like not.

#3 in reply to: ↑ description @SergeyBiryukov
7 years ago

Replying to pavelevap:

Release localized package for 3.8.1. But in this case there will be yellow message displayed to inform about new update. So, users have to update once again to latest localized version through Dashboard - Updates menu.

Yes, some users on support forums are indeed confused by these double updates.

#4 @nacin
7 years ago

I hope to have all of this fixed during the 4.0 cycle. Might be before 3.9.1, might not.

This ticket was mentioned in IRC in #wordpress-dev by SergeyBiryukov. View the logs.


7 years ago

#6 @m_uysl
7 years ago

Related: #29528

Last edited 7 years ago by SergeyBiryukov (previous) (diff)

#7 @ocean90
6 years ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #29528.

Note: See TracTickets for help on using tickets.