WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#27174 closed defect (bug) (worksforme)

Deprecated JS method warnings in tinymce editor

Reported by: Marventus Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8.1
Component: TinyMCE Keywords:
Focuses: Cc:

Description (last modified by SergeyBiryukov)

Hello, guys. I wanted to bring everyone's attention to the fact there seems to be several deprecated methods being used in the editor. This is not a problem per se, since everything works fo rnow, but it become one in the future if deprecated method calls are not updated.

While editing existing posts:

event.returnValue is deprecated. Please use the standard event.preventDefault() instead.
load-scripts.php?c=0&load%5B%5D=jquery-core,jquery-migrate,utils,plupload,plupload-html5,plupload-f…:4

body.scrollLeft is deprecated in strict mode. Please use 'documentElement.scrollLeft' if in strict mode and 'body.scrollLeft' only if in quirks mode.
tiny_mce.js?ver=359-20131026:1

body.scrollTop is deprecated in strict mode. Please use 'documentElement.scrollTop' if in strict mode and 'body.scrollTop' only if in quirks mode.

While creating new posts:

event.returnValue is deprecated. Please use the standard event.preventDefault() instead.
load-scripts.php?c=0&load%5B%5D=jquery-core,jquery-migrate,utils,plupload,plupload-html5,plupload-f…:4

'KeyboardEvent.keyLocation' is deprecated. Please use 'KeyboardEvent.location' instead.

Change History (3)

#1 follow-up: @adamsilverstein
7 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Thanks for submitting this report. At first I couldn't see the messages/warnings you were talking about because I was testing in firefox/firebug. Switching to chrome debugger I do the the warnings under WordPress 3.8.

Testing against trunk, however, I find all the warnings are gone. TinyMCE is getting a major update (to vs. 4) for WordPress 3.9 and this issue appears to have been fixed along the way.

I'm going to close the ticket for now because I believe the issue is resolved (or will be in the next release), if you still see the issue in trunk please feel free to re-open the ticket.

#2 in reply to: ↑ 1 @Marventus
7 years ago

Awesome, Adam! Thanks for looking into it. I knew about tinymce 4 and WP 3.9, but just wanted to make sure this didn't fall off the wagon.
Take care.

#3 @SergeyBiryukov
7 years ago

  • Description modified (diff)
  • Milestone Awaiting Review deleted

Related: #24067

Note: See TracTickets for help on using tickets.