WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#27214 closed defect (bug) (fixed)

Fix an undefined index.

Reported by: pross Owned by: SergeyBiryukov
Milestone: 3.9 Priority: normal
Severity: normal Version: 2.8
Component: Administration Keywords: has-patch commit
Focuses: Cc:

Description

When using the plugin editor with some plugins the following error is produced:

Undefined offset: 1370 in ..../wp-admin/includes/misc.php on line 321

Attached patch fixes the error.

Only some plugins are affected, which is weird. 'Debug Bar Slow Actions' was the one i tested the patch with.

Attachments (2)

patch.diff (1.0 KB) - added by pross 4 years ago.
27214.patch (1.1 KB) - added by SergeyBiryukov 4 years ago.

Download all attachments as: .zip

Change History (5)

@pross
4 years ago

#1 @bravokeyl
4 years ago

  • Keywords has-patch added

#2 @SergeyBiryukov
4 years ago

  • Component changed from General to Administration
  • Keywords commit added
  • Milestone changed from Awaiting Review to 3.9
  • Version changed from trunk to 2.8

Confirmed. Caused by missing closing ?> tag in the plugin file.

Introduced in [10607]. The upper limit for the loop is off, see 27214.patch.

Last edited 4 years ago by SergeyBiryukov (previous) (diff)

#3 @SergeyBiryukov
4 years ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from new to closed

In 27323:

Avoid an undefined index notice in wp_doc_link_parse().

props pross for initial patch.
fixes #27214.

Note: See TracTickets for help on using tickets.