WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#27226 closed defect (bug) (invalid)

Insert from URL fails when used via Plugin, because of missing quicktags javascript

Reported by: rhurling Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9
Component: Media Keywords:
Focuses: javascript Cc:

Description

See https://github.com/avryl/wp-front-end-editor/issues/34
and http://make.wordpress.org/ui/2014/02/27/front-end-editor-usability-test-1/#comment-24307

Reproduce:

  1. Enqueue media scripts with wp_enqueue_media
  2. Add necessary Markup
  3. Try to add Image via "Insert from URL"

Solution:
Enqueue quicktags in wp_enqueu_media or add as dependency to media-editor script

Notes:
I guess it went unnoticed most of the time because there's always the TinyMCE Editor somewhere on the page, which (i think) enqueues quicktags

Maybe related to #23591, although i'm not so sure about that

Change History (3)

#1 @rhurling
6 years ago

  • Resolution set to invalid
  • Status changed from new to closed

seems to have been fixed like 1 or 2 hours ago in trunk...

Lesson: Always update to latest trunk and try to reproduce again before creating a ticket (didn't realize trunk updated that often)

Last edited 6 years ago by rhurling (previous) (diff)

#2 @SergeyBiryukov
6 years ago

  • Milestone Awaiting Review deleted

#3 @kovshenin
6 years ago

Heh, just as I was playing around trying to reproduce this :) Yeah, trunk updates quite a few times a day, especially during beta season, so it's always a good idea to svn up prior to reporting a bug.

Note: See TracTickets for help on using tickets.