WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#27297 closed defect (bug) (duplicate)

Using "Post names" as Permalinks can lead to same url for a post and page.

Reported by: Da9L Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8.1
Component: Permalinks Keywords:
Focuses: Cc:

Description

To reproduce the error:
Use permalinks as "post name" meaning that the name of the post or page is used as identification for the url..

Create a page named news.. this will, with the above settings make a permalink looking like this: http://www.siteurl.com/news/

Then afterwards go make a post also named news.. This creates the same permalink (http://www.siteurl.com/news/), resulting in wierd behavior as you can imagine..

I believe this is a bug, since not so skilled users will be very confused as to what happens.

Change History (2)

#1 @jeremyfelt
8 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for the report, @Da9L. This is a duplicate of #13459.

#2 @SergeyBiryukov
8 years ago

  • Component changed from General to Permalinks
Note: See TracTickets for help on using tickets.