WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 7 years ago

#2730 closed defect (bug) (wontfix)

Page titled "page" cause unrecoverable problem on permalinks

Reported by: sdiz Owned by: matt
Milestone: Priority: normal
Severity: normal Version: 2.0.2
Component: General Keywords:
Focuses: Cc:

Description

The "page_uris" options not updated after deleteing the page.
Almost unrecoverable if I create a page called "page", or some other reserved names.

Have to enable "Date and name based" permalinks to repeat this bug.

Step To Reproduce

1) Go to http://yourhost/page/2

==> This page show the second page of the index, as expected

2) Add a new page, with a title called "page"

3) Go to http://yourhost/page/2

==> This give the page we just created.

4) Delete the "page" page.

5) Go to http://yourhost/page/2

==> This give "404"... *BAD*

Workaround:

1) rm -fr wp-content/cache/*

2) DELETE FROM wp_options WHERE option_name="rewrite_rules" OR option_name="page_uris";

3) go to permalinks option page, save


Change History (1)

comment:1 johnbillion7 years ago

  • Component changed from WordPress.org to General
  • Resolution set to wontfix
  • Status changed from new to closed

This bug is still present in 2.1 and r4999, however I'm going to take the liberty of closing it as wontfix due to the fact that this particular scenario is extremely unlikely to take place out in the wild. How many people have a page on their blog titled 'Page'?

Please reopen if you think this should be addressed.

Note: See TracTickets for help on using tickets.