WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#27306 closed defect (bug) (invalid)

Plugin update notifications only show in Network Admin, regardless of whether or not they are network activated.

Reported by: duanestorey Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.1
Component: Plugins Keywords:
Focuses: administration, multisite Cc:

Description

I'm not entirely sure if this is a bug, but it seems like new behaviour to me and it seems a bit strange from an end user perspective.

If you are using WordPress multisite, plugin update notifications only seem to appear in the network area, and not in the plugin list for each subsite.

To reproduce:

1) Set up WP multisite with a site, for example site1
2) Activate Hello Dolly on site1
3) Manually change the version in hello.php to something else
4) Update notification only shows for me in the Network plugin page, and not Site1's plugin page.

I'm happy to try and submit a patch for this if people agree it's a bug.

Change History (3)

#1 @SergeyBiryukov
7 years ago

Plugin update notifications are only shown in network admin since 3.1, see [16037].

In Multisite, plugins can only be updated in network admin anyway, so this appears to be a conscious decision.

#2 @SergeyBiryukov
7 years ago

  • Version changed from 3.8.1 to 3.1

#3 @SergeyBiryukov
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.