WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 5 years ago

#27323 closed enhancement (wontfix)

Show WordPress upgrade recommendation if a plugin has a higher recommended WordPress version than currently used

Reported by: harmr Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Plugins Keywords:
Focuses: administration Cc:

Description

My plugin "Leaflet Maps Marker" currently has 3.0 as minimum required WordPress version. With the next release I plan to increase this to 3.3.

This would mean that all current users on WordPress <3.3 will not see that there is an update available.

I think it could help motivate the administrator to upgrade WordPress to the latest version, if they also see that there were new plugin versions available they cannot use with their current installation.

This upgrade recommendation could be shown similar to regular available updates on on the plugins list.

Made a mockup: https://www.mapsmarker.com/dev/free/mockup-upgrade-recommendation-plugin.png

Change History (2)

#1 @SergeyBiryukov
7 years ago

  • Focuses administration added

#2 @DrewAPicture
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Hi @harmr,

Sorry it took so long for someone to get back to you.

With the workflow that's now in place on the plugin install screen, and with the language and design changes that have gone in over the last couple of releases, I think trying to also encourage incompatible users to upgrade WordPress would be a stretch.

The incompatibility message is now front-and-center in the plugin install screen and more detailed compatibility information is still available in the "More Details" modal.

http://f.cl.ly/items/181Z3H3E2s2A0u0B1J2j/Screen%20Shot%202015-08-21%20at%208.19.09%20PM.png

Thank you for the suggestion.

Note: See TracTickets for help on using tickets.