WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#27325 closed defect (bug) (duplicate)

Large number of pages eats memory and causes high server load.

Reported by: qwerty_123 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8.1
Component: Posts, Post Types Keywords:
Focuses: performance Cc:

Description

I'm on a powerful dedicated server and I'm the only person using the server.

Server Specs:

Dual Intel Xeon E5620 (16 x 2.4 GHz)
64 GB DDR3 RAM
4 x 1 TB HDD
Hardware RAID 10

I'm hosting 40 Wordpress installations alone, and am using the following plugins on each installation: Captcha by BestWebSoft (to prevent brute force login attempts through the admin interface), Exec-PHP (to insert custom PHP code in pages ... mainly to echo host information), and W3 Total Cache (to interface with Cloudfront, to cache pages, to cache objects, and to cache database queries), and Prosperent Suite (to showcase affiliate images and links). I'm also using Cloudflare to prevent hackers, spammers, etc.

My error_log shows that everything is working well and is not indicating errors in PHP.

To replicate this issue, create several wordpress installations (in my case, 40). Each wordpress installation should have between 1,000 and 50,000 pages with static html in them. Now, send in an artificial web crawler to simulate navigation through all those the pages on all those domains simultaneously.

What you'll see is a spike in server load, and each Apache process will consume between 100-300 MB of memory.

I've looked at Ticket #9864, and since I have thousands of pages in use, I agree that the server "hangs" when attempting to edit the page. However, it seems that #9864 is focused on the admin interface alone, e.g., editing a page. My focus here relates to how Wordpress goes about searching for a specific page when there are thousands of pages in the database to search from.

Attachments (1)

top-2.png (48.0 KB) - added by qwerty_123 6 years ago.
Screen Shot of Top

Download all attachments as: .zip

Change History (2)

@qwerty_123
6 years ago

Screen Shot of Top

#1 @SergeyBiryukov
6 years ago

  • Component changed from Permalinks to Posts, Post Types
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #15459.

Note: See TracTickets for help on using tickets.