WordPress.org

Make WordPress Core

Opened 14 years ago

Closed 14 years ago

#2737 closed defect (bug) (fixed)

Future Post Stripped of Images

Reported by: bloodylamer Owned by: ryan
Milestone: 2.1 Priority: high
Severity: major Version: 2.1
Component: General Keywords:
Focuses: Cc:

Description

When a post is published into the future, all the image tags that were initially in the post get stripped of the url and the post is published w/ only the text and blank spaces for where the image should've been.

After the future post automatically publishes, the code is changed to this:

<img />

THIS IS A TEST

Previously, there was a URL in the code.

Change History (5)

#1 @ringmaster
14 years ago

Is this symptom related to postmeta info getting stripped from future posts, too? I thought I might have imagined it, and haven't had a chance to test again to report it. But if you're looking into it...

#2 @bloodylamer
14 years ago

  • Version changed from 1.2 to 2.1

I want to update the properties of this ticket.

It is a bug in 2.1 Alpha 1, not 1.2.

#3 @ryan
14 years ago

  • Owner changed from anonymous to ryan

#4 @ryan
14 years ago

[4077] should fix this. The problem is when an unprivileged user triggered publishing of a future post. The filters would run as the unprivileged user.

#5 @mdawaffe
14 years ago

  • Milestone set to 2.1
  • Resolution set to fixed
  • Status changed from new to closed

Confirmed: fixed.

Note: See TracTickets for help on using tickets.