Make WordPress Core

Opened 10 years ago

Closed 10 years ago

#27396 closed enhancement (duplicate)

Add custom post type archives into menu

Reported by: spacedmonkey's profile spacedmonkey Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9
Component: Menus Keywords:
Focuses: administration Cc:

Description

It would be nice if there was a way to add custom post type archives into menus, without having to use the custom link functionality. Also if this is built in, it means that if the custom post type slug changes and link uses get_post_type_archive_link function, this slug change will automatically be corrected. It will also make it less confusing for less advanced users which have custom post types by an installed plugin.

I know there are a number of plugins that already do this, for example

http://wordpress.org/plugins/cpt-archives-in-nav-menus/

But it would be nice if it was added to core.

Change History (1)

#1 @helen
10 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #16075.

Note: See TracTickets for help on using tickets.