WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#27422 closed defect (bug) (fixed)

Tapping an image in TinyMCE that is wrapped in link follows the link instead of opening modal

Reported by: gcorne Owned by:
Milestone: 3.9 Priority: normal
Severity: normal Version: 3.9
Component: TinyMCE Keywords:
Focuses: ui, javascript Cc:

Description

At least on iOS 7.1 / Chrome, when tapping an image in TinyMCE that is wrapped with a link, the link is followed. This is a regression from 3.8.

Change History (5)

#1 @azaozz
6 years ago

  • Keywords close added

Conformed. Was working properly in 7.0.

Seems Chrome in iOS 7.1 is quite buggy. It also follows text links in contenteditable mode (afaik no other browser has done that since contenteditable was introduced). Also crashed several times while trying to select text (to add a link).

Don't think we can do anything to fix it, should be fixed in the browser.

#2 @gcorne
6 years ago

The issue also occurs in Safari on iOS 7.1, so I think we should probably try and fix it.

#3 @azaozz
6 years ago

Yes, passed upstream and fix is coming up.

#4 @azaozz
6 years ago

  • Keywords close removed

#5 @nacin
6 years ago

  • Resolution set to fixed
  • Status changed from new to closed

I can confirm this now works in WP trunk on iOS 7.1 (iPad mini) for both Chrome and Safari.

Appears to have been fixed in TinyMCE 4.0.20: http://www.tinymce.com/develop/changelog/?ctrl=version&act=view&pr_id=1&vr_id=860

This version adds a few workarounds for iOS 7.1. Apple introduced two new bugs in their latest Safari version where it's possible to tap and open links within a contentEditable region and get the touch call out menu on links/images we managed to disable these to "features".

4.0.20 was added to trunk in [27603], after this ticket was opened.

Note: See TracTickets for help on using tickets.