WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#27454 closed enhancement (duplicate)

Customizer file uploader should indicate when an upload is happening

Reported by: cliffseal Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8
Component: Customize Keywords: has-patch close
Focuses: ui, javascript Cc:

Description

When dragging an image into the 'Drop a file here or...' area in the customizer, nothing indicates an image is being uploaded. That's confusing, and can lead to multiple uploads of the same file—especially if they're larger files on a slower server.

We should change 'Drop a file here or...' to 'Uploading...' or an AJAX spinner while the image is being uploaded.

Attachments (2)

27454-1.diff (793 bytes) - added by cliffseal 6 years ago.
27454-2.diff (732 bytes) - added by cliffseal 6 years ago.

Download all attachments as: .zip

Change History (12)

#1 @SergeyBiryukov
7 years ago

  • Component changed from Themes to Appearance

#2 @SergeyBiryukov
7 years ago

  • Version changed from trunk to 3.8

#3 @westonruter
6 years ago

We could utilize the new processing state in 3.9 to indicate when the spinner should be displayed. This is used in Widget Customizer to prevent saving the settings before the Widget logic can return with the sanitized widget instances. We could also increment the processing state when an image upload is happening, and show a spinner when processing is not 0.

#4 @westonruter
6 years ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 4.0

@cliffseal
6 years ago

#5 @cliffseal
6 years ago

  • Keywords has-patch added; needs-patch removed

Here's an example to get us started. I'd love to see a more elegant way to go for it, but this shows how easy it could be to accomplish this extra little piece for users.

@cliffseal
6 years ago

#6 @cliffseal
6 years ago

Conversely, we can plug these calls into customize-controls.js, which is probably a better decision as far as scope goes. 27454-2.diff is a demonstration of this.

#7 @westonruter
6 years ago

  • Keywords close added

I suggest that we close this in favor of #21483, which eliminate the current upload control for background images and instead handle uploading inside of the Media Manager modal. All uploads can be done via the Media Manager.

Last edited 6 years ago by westonruter (previous) (diff)

#8 @cliffseal
6 years ago

@westonruter Agreed, though I saw in that thread that the idea was being tossed around to keep the upload drop zone in addition to the button to open the library. If the dropzone stays, we should an an 'uploading' indicator.

#9 follow-up: @nacin
6 years ago

  • Milestone 4.0 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #21483.

I like the idea of a dropzone that opens the media manager. That's about the extent of which I'd like this control to remain.

Worth remembering that the customizer (3.4) came before the media manager (3.5). We definitely would have done the customizer differently if it were the other way around.

#10 in reply to: ↑ 9 @cliffseal
6 years ago

Replying to nacin:

I like the idea of a dropzone that opens the media manager. That's about the extent of which I'd like this control to remain.

Right on. That's an indication the upload is happening just as well.

...almost got some code into core this time, though! :D

Note: See TracTickets for help on using tickets.