WordPress.org

Make WordPress Core

Opened 16 years ago

Closed 15 years ago

Last modified 14 years ago

#2746 closed defect (bug) (worksforme)

Replace < and > sign in title for links

Reported by: koendr Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.0.2
Component: General Keywords:
Focuses: Cc:

Description

Inserting a link on text works succesful. But using < and > signs in the title for that link gives errors due to not translating them to their html entities. Further page content is interpreted wrong by browser.

Change History (4)

#1 @skeltoac
16 years ago

Three things make a bug report workable:

Steps to reproduce. (Which editor? Don't be vague.)

What you expected. (Done.)

What happened. (Done.)

Please fill in the missing information.

#2 @filosofo
15 years ago

Step to reproduce:
Make this your title: Check out <a href="http://www.cnn.com" title="CNN > others">this site</a>

However, since titles are usually within anchor tags, this would produce invalid XHTML (nested links) anyways.

#3 @Nazgul
15 years ago

  • Milestone set to 2.1
  • Resolution set to worksforme
  • Status changed from new to closed

This appears to be already fixed in trunk.

#4 @Nazgul
14 years ago

  • Milestone 2.1 deleted
Note: See TracTickets for help on using tickets.