WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#27501 closed defect (bug) (invalid)

Dashboard security warnings for Internet Explorer 11

Reported by: DGN1nja Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8.1
Component: Administration Keywords:
Focuses: administration Cc:

Description

Using WP with IE11 enables the insecure browser nag on the dashboard, which warns users to upgrade their insecure version of Internet Explorer. I assume that adding IE11 to the list of acceptable IE versions is an easy fix for this.

IE 11.0.9600.16521 (11.0.4) on Windows 8.1 Pro, both x64.

Change History (5)

#1 @jesin
8 years ago

Hi DGN1nja,

Enabling compatibility view on IE11 changes the user agent string to match IE7 which triggers this error. On IE11 compatibility view is automatically enabled on Intranet sites so I guess you are facing this problem on a local installation of WordPress.

Open IE, navigate to Tools menu > Compatibility View settings and uncheck Display intranet sites in Compatibility View.

#2 follow-up: @DGN1nja
8 years ago

I should have checked compatibility view first, my bad. Can't this be fixed with a X-UA-Compatible: IE=edge header, though? Or is this issue not large enough to merit adding code?

#3 in reply to: ↑ 2 @SergeyBiryukov
8 years ago

Replying to DGN1nja:

Can't this be fixed with a X-UA-Compatible: IE=edge header, though?

We already set that via an HTTP header, see #25575.

#4 @DGN1nja
8 years ago

  • Resolution set to invalid
  • Status changed from new to closed

#5 @SergeyBiryukov
8 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.