WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 years ago

#27517 closed enhancement (duplicate)

Add sorting option to get_blogs_of_user

Reported by: daniloercoli Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Networks and Sites Keywords:
Focuses: multisite Cc:

Description

The blogs list returned by the function get_blogs_of_user does seem sorted by creation time.

Would be nice to add an optional parameter that can be used to add/modify the sorting behavior.

Attachments (1)

24398.patch (2.3 KB) - added by tubiz 6 years ago.

Download all attachments as: .zip

Change History (4)

#1 @nofearinc
7 years ago

  • Component changed from General to Networks and Sites
  • Focuses multisite added

It's worth mentioning that a get_blogs_of_user hook is applied on return:

    return apply_filters( 'get_blogs_of_user', $blogs, $user_id, $all );

@tubiz
6 years ago

#2 @tubiz
6 years ago

Please can the patch that I added be deleted.
The patch is meant for another ticket.
Thanks

#3 @jeremyfelt
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #15828.

Note: See TracTickets for help on using tickets.