Make WordPress Core

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#2752 closed defect (bug) (wontfix)

link_pages space missing

Reported by: vxnick Owned by:
Milestone: Priority: low
Severity: trivial Version: 2.0.2
Component: Template Keywords:
Focuses: Cc:



In reference to ticket 1477, I have created a new patch based on skippy's existing patch.

I can confirm that this works on my 2.1 Alpha and 2.0.2 installations.

To customise the separator, you need to specify one additional parameter (at the end of the function, to avoid breaking things):

link_pages($before, $after, $next_or_number, $nextpagelink, $previouspagelink, $pagelink, $more_file, $sep);

The new $sep variable defaults to one space character to separate the 'previous' and 'next' text when using <!--nextpage-->.

My apologies if I've missed anything out - this is my first Wordpress patch, and first time using Trac.


Attachments (2)

template-functions-post.php.diff (953 bytes) - added by vxnick 9 years ago.
Patch to add $sep variable for customising separator.
template-functions-post.php-2.diff (988 bytes) - added by vxnick 9 years ago.
Second patch to hide $sep characters.

Download all attachments as: .zip

Change History (8)

@vxnick9 years ago

Patch to add $sep variable for customising separator.

comment:1 @vxnick9 years ago

  • Milestone set to 2.0.3
  • Priority changed from normal to low

comment:2 @davidhouse9 years ago

  • Keywords bg|has-patch added

@vxnick9 years ago

Second patch to hide $sep characters.

comment:3 @vxnick9 years ago


I've just attached a newer patch to address the following:

When using the new $sep variable, it would show the $sep value on the last page, after the 'previouspagelink', and on the first page before 'nextpagelink'.

This patch now hides the $sep value if on the first or last page.


comment:4 @vxnick9 years ago


It seems this patch stops the Pages from showing in the Sidebar - any ideas why?


comment:5 @foolswisdom9 years ago

  • Keywords bg|has-patch removed
  • Resolution set to wontfix
  • Status changed from new to closed

As above this relates to ticket #1477 which has not been updated in a year.

Removing has-patch tag because last comment suggests it breaks functionality.

Marking WONTFIX for now.

comment:6 @anonymous9 years ago

  • Milestone 2.0.3 deleted

Milestone 2.0.3 deleted

Note: See TracTickets for help on using tickets.