WordPress.org

Make WordPress Core

#27534 closed defect (bug) (fixed)

Review inline docs/coding standards for wp-includes/class-wp-customize-widgets.php

Reported by: ocean90 Owned by: DrewAPicture
Milestone: 3.9 Priority: high
Severity: normal Version:
Component: Customize Keywords:
Focuses: docs Cc:

Description

  • Remove @action/@filter tags
  • Add missing method descriptions
  • Add missing tags like @since
  • Remove UPDATE_WIDGET_AJAX_ACTION/UPDATE_WIDGET_NONCE_POST_KEY constants
  • Think about lines L71-L95

For now, Options_Transaction can be ignored, see #27504.

Attachments (3)

27534.diff (23.8 KB) - added by DrewAPicture 13 months ago.
Docs: first pass.
27534.2.diff (2.1 KB) - added by DrewAPicture 13 months ago.
_capture_* tweaks
27534.3.diff (1.5 KB) - added by ocean90 13 months ago.
Minior things, should be included in a next commit.

Download all attachments as: .zip

Change History (15)

comment:1 @DrewAPicture13 months ago

  • Owner set to DrewAPicture
  • Status changed from new to assigned

comment:2 @ircbot13 months ago

This ticket was mentioned in IRC in #wordpress-dev by DrewAPicture. View the logs.

@DrewAPicture13 months ago

Docs: first pass.

comment:3 @ocean9013 months ago

In 27753:

Widget Customizer: First pass for inline docs.

props DrewAPicture.
see #27534.

comment:4 @ocean9013 months ago

In 27818:

Widget Customizer: Remove UPDATE_WIDGET_AJAX_ACTION and UPDATE_WIDGET_NONCE_POST_KEY constants.

see #27534.

comment:5 @ocean9013 months ago

In 27819:

Widget Customizer: Simplify nonces.

see #27534.

comment:6 @DrewAPicture13 months ago

#27531 was marked as a duplicate.

comment:7 @ircbot13 months ago

This ticket was mentioned in IRC in #wordpress-dev by DrewAPicture. View the logs.

comment:8 @DrewAPicture13 months ago

In 27903:

Second-pass inline documentation improvements for WP_Customize_Widgets.

See #27534.

comment:9 @DrewAPicture13 months ago

In 27904:

Coding standards and readability spacing for WP_Customize_Widgets.

Also explicitly re-mark _capture_filter_pre_update_option() and _capture_filter_pre_get_option() as public.

See #27534.

@DrewAPicture13 months ago

_capture_* tweaks

comment:10 @DrewAPicture13 months ago

I propose since both _capture_filter_pre_update_option() and _capture_filter_pre_get_option() are actually public we should remove the leading underscores. This is done in 27534.2.diff along with fixing an incorrect hook name in stop_capturing_option_updates().

comment:11 @ocean9013 months ago

In 27910:

Widget Customizer: Remove leading underscores from public methods.

Fix also an incorrect hook name in stop_capturing_option_updates().

props DrewAPicture.
see #27534.

@ocean9013 months ago

Minior things, should be included in a next commit.

comment:12 @ocean9013 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 27968:

Widget Customizer: Minor code cleanup.

  • Remove type hinting from WP_Customize_Widgets
  • Rename inject_preview_css to print_preview_css
  • Remove stray @todo

fixes #27534.

Note: See TracTickets for help on using tickets.