Make WordPress Core

Opened 10 years ago

Closed 10 years ago

Last modified 3 years ago

#27547 closed defect (bug) (fixed)

Can not use Pages Menu in wp-Admin

Reported by: gkinghost's profile gkinghost Owned by:
Milestone: 3.9 Priority: high
Severity: normal Version: 3.9
Component: Posts, Post Types Keywords:
Focuses: administration Cc:

Description

In admin area, when i click Menu pages
ex (my site http://thietkenhaxanh.com/wp-admin/edit.php?post_type=page)
The list show is list of post ,not list of pages

http://i.imgur.com/g6e07ni.png
List page is hidden
Thanks
my English is very bad

Change History (15)

#1 follow-up: @SergeyBiryukov
10 years ago

  • Component changed from Cron API to Posts, Post Types
  • Focuses administration added
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Please try the support forums: ​http://wordpress.org/support/.

#2 in reply to: ↑ 1 @gkinghost
10 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Replying to SergeyBiryukov:

Please try the support forums: ​http://wordpress.org/support/.

It shows when i update to wp 9 beta 2

#3 @NateWr
10 years ago

I was able to replicate this by installing a copy of 3.9 beta 1 and using the automated upgrade process.

Here's what I did:

  1. Installed a fresh copy of 3.9 beta 2. The problem was not there.
  1. Installed a fresh copy of 3.9 beta 1 and still no problem.
  1. Updated from 3.9 beta 1 to beta 2 using the WordPress admin area's "Update" page. The problem then appeared.

I am using a localhost development environment on WAMP (Win 7, PHP 5.3.8, MySQL 5.5.16).

#4 @SergeyBiryukov
10 years ago

  • Keywords reporter-feedback added
  • Milestone set to Awaiting Review

Does it still happen with all plugins disabled and a default theme (Twenty Fourteen or Twenty Thirteen) activated?

#5 @NateWr
10 years ago

Yes, these were completely fresh installs, unzipped to their own folders, placed on newly created databases. No plugins or themes installed aside from what shipped with the beta 1 and 2 zip files.

#6 @NateWr
10 years ago

It appears that the post type is "lost". The URL correctly identifies the post type as "page":

http://localhost/wp39b1/wp-admin/edit.php?post_type=page

But the post type is not getting added in the hidden field of the search/filter form:

<input type="hidden" name="post_type" class="post_type_page" value="" />

"Post" is likely just the default fallback post type.

#7 @samuelsidler
10 years ago

  • Milestone changed from Awaiting Review to 3.9
  • Priority changed from normal to high
  • Severity changed from normal to major

Reproduced using the steps in comment 3. We probably need to fix this.

#8 @gkinghost
10 years ago

  • Severity changed from major to normal

the pages dont shows in screen but when i view source of that i see list name of pages

this is "<option class="level-0" value="197">Page name</option>"

<fieldset class="inline-edit-col-right"><div class="inline-edit-col">

	<label class="inline-edit-author"><span class="title">Author</span><select name='post_author' class='authors'>
	<option value='-1'>&mdash; No Change &mdash;</option>
	<option value='1'>admin</option>
</select></label>			<label>
				<span class="title">Parent</span>
	<select name='post_parent' id='post_parent'>
	<option value="-1">&mdash; No Change &mdash;</option>	<option value="0">Main Page (no parent)</option>
	<option class="level-0" value="197">Advertisement</option>
	<option class="level-0" value="438">BẢNG GIÁ THI CÔNG</option>
	<option class="level-0" value="412">BẢNG GIÁ THIẾT KẾ</option>
	<option class="level-0" value="97">Boxes</option>
	<option class="level-0" value="91">Buttons</option>
	<option class="level-0" value="142">Columns</option>
	<option class="level-0" value="162">Display Feed</option>
	<option class="level-0" value="477">dzfvcwsdfv</option>
	<option class="level-0" value="160">GIỚI THIỆU</option>
	<option class="level-0" value="174">Login Required</option>
	<option class="level-0" value="244">Multiple Pages</option>
	<option class="level-0" value="223">Page / Post Elements</option>
	<option class="level-0" value="487">refcre</option>
	<option class="level-0" value="2">Sample Page</option>
	<option class="level-0" value="307">Sample Page</option>
	<option class="level-0" value="89">SHORTCODES</option>
	<option class="level-0" value="165">Sitemap</option>
	<option class="level-0" value="107">Socail</option>
	<option class="level-0" value="102">Tabs and Toggles</option>
	<option class="level-0" value="169">Tags</option>
	<option class="level-0" value="257">Text and Lists</option>
	<option class="level-0" value="151">text and lists</option>
	<option class="level-0" value="315">TiePanel</option>
	<option class="level-0" value="172">Timeline</option>
	<option class="level-0" value="213">Tooltips</option>
	<option class="level-0" value="114">Video and Audio</option>
</select>
			</label>

	
			<label>
				<span class="title">Template</span>
				<select name="page_template">
						<option value="-1">&mdash; No Change &mdash;</option>
						<option value="default">Default Template</option>

#9 @WraithKenny
10 years ago

I've updated a localhost dev install yesterday, and this didn't happen, but today (updated on a different machine/install) I duplicated this: my pages list is listing my posts. So perhaps this is a recent commit. Also, selecting any filter leads to an invalid post type error screen ("?post_type=&").

#10 @nacin
10 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

This was fixed in trunk with [27768]. #23862 explains how [27738] broke things. I'll push a new nightly so the nightly isn't borked for the next 7 hours.

#11 @nacin
10 years ago

#27549 was marked as a duplicate.

#12 @SergeyBiryukov
10 years ago

  • Keywords reporter-feedback removed

So, this was introduced in [27738] and fixed in [27768]. See the explanation in comment:10:ticket:23862.

The current nightly build is broken, but trunk is not. Should be fixed on the next update of the nightly build.

Version 0, edited 10 years ago by SergeyBiryukov (next)

#13 @mrppp
10 years ago

Superb updated now all back

#14 @SergeyBiryukov
10 years ago

  • Version changed from 3.8 to trunk
Note: See TracTickets for help on using tickets.