WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 3 months ago

#27559 closed enhancement (duplicate)

Improve <figure> handling

Reported by: johnbillion Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9
Component: Formatting Keywords: wpautop
Focuses: Cc:

Description

Follow up to #25646.

We need to look at wpautop()'s handling of the <figure> element and see if it's optimal. Currently a <br> gets inserted when using a <figcaption> inside a <figure>.

Change History (3)

#1 @miqrogroove
5 years ago

  • Keywords wpautop added

#2 @henry.wright
3 years ago

According to the MDN, <figcaption> is a block-level element so inserting a <br> tag isn't strictly necessary.

Ref: https://developer.mozilla.org/en/docs/Web/HTML/Block-level_elements

#3 @pento
3 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #39307.

Note: See TracTickets for help on using tickets.