WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 years ago

#27561 closed defect (bug) (fixed)

Installed theme search searches html

Reported by: samuelsidler Owned by: SergeyBiryukov
Milestone: 4.2 Priority: normal
Severity: normal Version: 3.9
Component: Themes Keywords: has-patch
Focuses: ui, administration Cc:

Description

Spin off from #27136.

On the installed theme page, when you search, it will search HTML as well (e.g., if a <strong> tag is there, it'll find it).

We fixed this for plugins in 27136 and need to fix it for themes now.

Attachments (1)

27561.diff (1.1 KB) - added by obenland 6 years ago.

Download all attachments as: .zip

Change History (10)

#1 @DrewAPicture
6 years ago

  • Keywords reporter-feedback added

Can't confirm this is still a problem. It looks like this was fixed at some point.

#2 @MikeHansenMe
6 years ago

I just tested this and was also unable to reproduce.

#3 @samuelsidler
6 years ago

  • Milestone Future Release deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Works for me.

#4 @SergeyBiryukov
6 years ago

  • Component changed from Administration to Themes
  • Focuses administration added
  • Keywords reporter-feedback removed
  • Milestone set to Awaiting Review
  • Resolution worksforme deleted
  • Status changed from closed to reopened

I can still reproduce in current trunk, with the same steps as in comment:5:ticket:27136:

  1. Add <strong>test</strong> somewhere in a theme description.
  2. Search for "strong".

On a related note, there should be a message instead of a blank screen if no themes are found: #28587.

#5 @jacklenox
6 years ago

I've tested this patch (https://core.trac.wordpress.org/attachment/ticket/27136/27136.diff) and it definitely works for me.

However it doesn't appear to have been committed in current trunk.

#6 @obenland
6 years ago

  • Keywords 4.0-early removed
  • Milestone changed from Awaiting Review to 4.2

@obenland
6 years ago

#7 @obenland
6 years ago

  • Keywords has-patch added; needs-patch removed

I did some performance tests on the patch and I don't share nacin's performance concerns. I also tested it with 399 themes on WordPress.com, and I could not make out any delays caused by the change.

This ticket was mentioned in Slack in #core by obenland. View the logs.


6 years ago

#9 @SergeyBiryukov
6 years ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from reopened to closed

In 31240:

Strip HTML tags when searching for installed themes.

props enej, SergeyBiryukov, obenland.
fixes #27561.

Note: See TracTickets for help on using tickets.