WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#2757 closed defect (bug) (duplicate)

Page Order doesn't render in default Wordpress theme

Reported by: mobilehippie Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.0.2
Component: General Keywords: functions page order
Focuses: Cc:

Description

While installing Wordpress for a client, we realized that the client's chosen page order wasn't being rendered properly.

The theme we are implementing is based on the Kubrick default. I've double checked this on a couple of other installs and while parent-child relationships are properly nested, the page order in the sidebar (as called by wp_list_pages()) is using alphabetical order as opposed to the assigned order.

Change History (3)

comment:1 johnbillion7 years ago

The problem lies in wp_list_pages (wp-includes/post-template.php) as it doesn't take into account the page order specified on the page writing screen.

comment:2 johnbillion7 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Marking as duplicate of #3923 as that ticket has a patch.

comment:3 johnbillion7 years ago

Please see #3924 for a fix for this in core.

Note: See TracTickets for help on using tickets.