WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#27576 closed defect (bug) (invalid)

In posts, category and tags some texts are not being converted to current language

Reported by: PurpleMAD Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8.1
Component: I18N Keywords:
Focuses: Cc:
PR Number:

Description

Hello,

We have found some texts which are not being converted to other languages as not language support is provided there. Kindly check below screenshots for the reference.

http://mim.purplemadprojects.com/Listing_post.png
http://mim.purplemadprojects.com/Add_post.png
http://mim.purplemadprojects.com/Listing_and_add_tags.png
http://mim.purplemadprojects.com/Listing_and_add_category.png

Can you check and see if that can be solved in next version?

Thank you,
PurpleMAD

Attachments (1)

Bugs.zip (277.3 KB) - added by PurpleMAD 6 years ago.

Download all attachments as: .zip

Change History (7)

@PurpleMAD
6 years ago

#1 @jesin
6 years ago

  • Component changed from Text Changes to I18N

Hi PurpleMAD,

Those lines of text are definitely translatable but no translation is available for them in that language.

Look at these screenshots of the "Add/Edit Post" & "List Post" pages in German de_DE.

https://imgur.com/GRLkXDD.png

https://i.imgur.com/ionlycN.png

#2 @SergeyBiryukov
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

This is an issue with a particular translation, not with core.

Either the multilanguage plugin is pulling wrong translation files, or those strings are not translated.

This should be reported either to the plugin author or to the Chinese translation team.

#3 @PurpleMAD
6 years ago

  • Keywords needs-codex needs-docs added
  • Resolution invalid deleted
  • Status changed from closed to reopened

Hello,

Thank you for replay our query.

We have uploaded http://wordpress.org/plugins/woocommerce/ plugin and my current word press language is german.Still we have found some texts which are not being converted to other languages as not language support is provided there. Kindly check below screenshots for the reference.

http://mim.purplemadprojects.com/product.png
http://mim.purplemadprojects.com/product_category.png
http://mim.purplemadprojects.com/Add_post.png
http://mim.purplemadprojects.com/Listing_and_add_category.png

Can you check and Given to proper solution

Note : We have used WordPress Language plugin for translation in admin panel.

kindly check : http://wpml.org/documentation/related-projects/wordpress-language/

Thank you,
PurpleMAD

Last edited 6 years ago by PurpleMAD (previous) (diff)

#4 @ocean90
6 years ago

  • Keywords needs-codex needs-docs removed
  • Resolution set to invalid
  • Status changed from reopened to closed

Hello PurpleMAD,

this is not a bug in core. Please don't re-open the ticket.
You should get in contact with the plugin authors, or try the support forums: https://wordpress.org/support/.

Try also to download the language files again and replace them with existing ones: http://wpde.org/download/sprachdateien/

#5 @SergeyBiryukov
6 years ago

All these strings are translatable in core.

The issue is in the WordPress Language plugin you're using. Instead of loading language files for the latest stable release from GlotPress, it loads a list of outdated language files from a third-party resource:
https://plugins.trac.wordpress.org/browser/wordpress-language/tags/1.1.1/inc/auto-download-locales.php#L12

Here's the list of files it has for German:
http://d2pf4b3z51hfy8.cloudfront.net/3.4.x/de.mo
http://d2pf4b3z51hfy8.cloudfront.net/dev/de.mo
http://d2pf4b3z51hfy8.cloudfront.net/3.5.x/de.mo
http://d2pf4b3z51hfy8.cloudfront.net/3.4.x/admin/network/de.mo
http://d2pf4b3z51hfy8.cloudfront.net/dev/admin/network/de.mo
http://d2pf4b3z51hfy8.cloudfront.net/3.5.x/admin/de.mo

It discards 3.4.x and 3.5.x files, as well as admin/network, and only loads dev/de.mo file (which is outdated too and only contains front-end strings).

I'd suggest using WP Native Dashboard plugin instead.

#6 @PurpleMAD
6 years ago

Hello,

Thank you for reply our query.
Now It is working.

Thank you,
PurpleMAD

Last edited 6 years ago by PurpleMAD (previous) (diff)
Note: See TracTickets for help on using tickets.