Make WordPress Core

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#27580 closed defect (bug) (duplicate)

Wordpress Importer should, by default, map usernames to pre-existing users with same name.

Reported by: alexbowyer's profile alexbowyer Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8.1
Component: Import Keywords:
Focuses: ui, administration Cc:

Description

Hi,
Often web developers using WP need to use Wordpress Import & Export to transfer data between dev/staging/production, and often these imports have to be split up into several import tasks by language or to reduce the size. Currently, this is very tedious for the subsequent imports, because you have to select the right user name in every single drop down (or have all your posts relabelled as the current user e.g. admin). On my site import I was doing today I had 40 users, and 6 import files. This meant selecting names which exactly match the name next to the drop down, 240 times.

It seems to me that the current default behaviour upon finding an already-existing user with the same name as the user in the import file, does not match the most common use case. Currently it tries to create a new user with that name, fails because it already exists, then maps the posts to the current user. Meaning you have to manually trash them, delete permanently, and re-import, then go through the painful drop down selection procedure again.

There is a plugin that fixes this (http://wordpress.org/plugins/displet-auto-select-authors-during-import/) which changes the default behaviour when an already-existing user is found to automatically map the posts by the user with the same username to that pre-existing user. It seems to me that 99% of the time this is the behaviour people want, not to map posts to admin.

Maybe this made sense at some point in the past of Wordpress but the current behaviour seems broken, I would like to see the behaviour that displet offers become the default behaviour. Or at the very least have a single button or checkbox to auto-set all drop downs to "auto-map where username is the same".

Thanks for listening.
Alex Bowyer

Change History (2)

#1 @SergeyBiryukov
10 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #8455.

#2 @lkraav
10 years ago

I wholeheartedly appreciate the pointer to that plugin. Real life quality improver that one.

Note: See TracTickets for help on using tickets.