WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#27609 closed defect (bug) (wontfix)

change `<code>` to `<pre>` in wp-includes/comment-template.php

Reported by: ritterml Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8.1
Component: Comments Keywords: reporter-feedback
Focuses: Cc:

Description (last modified by SergeyBiryukov)

Change <code> to <pre> in "allowed tags" on line 2002 to avoid "nowrap" errors in Bootstrap. <code> block expands beyond container block when white-space:nowrap is applied.

Notes:

  • <code> is for in-line, not block-level
  • these tags should be in an unordered list

Considered adding a foreach loop to wrap each allowed_tags() in a <li> and <code>, which is more semantic.

    foreach(allowed_tags() as $t)
    return "<li><code>$t</code></li>"

Change History (5)

#1 @ritterml
6 years ago

Now that I think of it, the foreach loop I mentioned should probably be wrapped into allowed_tags() to keep it out of the View.

#2 @SergeyBiryukov
6 years ago

  • Description modified (diff)

Rather than focus on the solution, could you describe what the issue is, and how to reproduce it?

#3 @DrewAPicture
6 years ago

  • Component changed from General to Comments
  • Keywords reporter-feedback added

@ritterml: Care to followup here? See comment:2

#4 @joedolson
6 years ago

  • Focuses accessibility removed

This is somewhat interesting, but it would have significant breakages in themes, and I don't see a lot of value in catering specifically to Bootstrap issues. There are no accessibility concerns on this that aren't 100% controllable in themes (avoiding overflow of containers), so I recommend closing this issue.

I'm removing the accessibility focus, at any rate.

#5 @johnbillion
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Please re-open if there is a strong case for this.

Note: See TracTickets for help on using tickets.