WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#27633 closed enhancement (fixed)

Pass plugin/theme update objects to upgrader & add plugin/theme autoupdate stats

Reported by: dd32 Owned by: nacin
Milestone: 3.9 Priority: normal
Severity: normal Version: 3.7
Component: Upgrade/Install Keywords: dev-feedback
Focuses: Cc:
PR Number:

Description

The Background Updater functionality has always had the ability for users to opt-in for plugin & theme autoupdates through the usage of plugins or filters, but we've got no stats on the effectiveness of any of these updates, or, if they're experiencing different rates of success (be it better or worse).

Currently we report autoupdate statistics to WordPress.org for Core Updates, these have been invaluable for evaluating the Background Updates successes and failures, so it makes sense to record similar data for plugins & themes as well.

Due to #27365 we only have a success or failure available to us (and no idea why it failed), but it's enough data for this purpose for now.

In adding these stats, it was discovered that we were incorrectly passing plugin/theme slugs to the updater, rather than the update offerings (which we do for Core & Translations), this change brings it inline with the expected behaviour and documentation.
There should be no significant breakage caused by that, in the worst case scenario someone who has explicitly opted in to receive updates for a single plugin may no longer do so, those who simply opted in to receive all updates (through add_filter( 'auto_update_plugin', '__return_true' ); as most tutorials suggest) would see no change.

Attachments (1)

27633.diff (1005 bytes) - added by dd32 6 years ago.

Download all attachments as: .zip

Change History (13)

#1 @dd32
6 years ago

In 27905:

Background Updates: Record Plugin & Theme update statistics like we for for Core updates, Pass Plugin/Theme update objects into the Background updater for consistency with Core & Translations. See #27633

#2 @nacin
6 years ago

  • Owner set to nacin
  • Resolution set to fixed
  • Status changed from new to closed

In 27923:

Background Updates: Record plugin & theme update statistics like we do for core updates.

Pass plugin/theme update objects into the Background updater for consistency with core & translations.

Merges [27905] to the 3.8 branch.

props dd32.
fixes #27633.

#3 @nacin
6 years ago

In 27924:

Background Updates: Record plugin & theme update statistics like we do for core updates.

Pass plugin/theme update objects into the Background updater for consistency with core & translations.

Merges [27905] to the 3.7 branch.

props dd32.
fixes #27633.

#4 follow-up: @DrewAPicture
6 years ago

  • Keywords dev-feedback added
  • Resolution fixed deleted
  • Status changed from closed to reopened

Getting some warnings on plugin and theme upgrades following [27905]:

PHP Warning:  json_encode(): recursion detected in /srv/www/trunk/src/wp-includes/update.php on line 261
PHP Warning:  json_encode(): recursion detected in /srv/www/trunk/src/wp-includes/update.php on line 405

#5 in reply to: ↑ 4 @dd32
6 years ago

Replying to DrewAPicture:

Getting some warnings on plugin and theme upgrades following [27905]:

PHP Warning:  json_encode(): recursion detected in /srv/www/trunk/src/wp-includes/update.php on line 261
PHP Warning:  json_encode(): recursion detected in /srv/www/trunk/src/wp-includes/update.php on line 405

Are these occurring during auto updates? Manual updates? A specific page?

@dd32
6 years ago

This ticket was mentioned in IRC in #wordpress-dev by dd32. View the logs.


6 years ago

#7 @dd32
6 years ago

r27906 is also supposed to be here, I missed including a Ticket reference.

#8 @dd32
6 years ago

In 27928:

Background Updates: Fix a PHP Warning caused by a Upgrader instance being passed into the Theme & Plugin $extra_stats parameter. See #27633

#9 @dd32
6 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 27929:

Background Updates: Fix a PHP Warning caused by a Upgrader instance being passed into the Theme & Plugin $extra_stats parameter.
Background Updates: Fix two variable typos in r27905

Merges [27906], [27928] to the 3.8 branch.
Fixes #27633.

#10 @dd32
6 years ago

In 27930:

Background Updates: Fix a PHP Warning caused by a Upgrader instance being passed into the Theme & Plugin $extra_stats parameter.
Background Updates: Fix two variable typos in r27905

Merges [27906], [27928] to the 3.7 branch.
Fixes #27633.

#11 @dd32
6 years ago

#27653 was marked as a duplicate.

#12 @dd32
6 years ago

#27654 was marked as a duplicate.

Note: See TracTickets for help on using tickets.