WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#27634 closed defect (bug) (fixed)

prepend_attachment() produces a warning if attachment type is not image, video or audio.

Reported by: ocean90 Owned by: wonderboymusic
Milestone: 3.9 Priority: normal
Severity: normal Version: 3.9
Component: Media Keywords: has-patch
Focuses: template Cc:

Description

Original report: https://wordpress.org/support/topic/prepend_attachment-does-not-handle-all-mime-types-eg-text

Before [27622] the attachment was wrapped in <p> element for every MIME type. We should restore this behavior.

Attachments (1)

27634.patch (1.3 KB) - added by ocean90 7 years ago.

Download all attachments as: .zip

Change History (3)

@ocean90
7 years ago

#1 @SergeyBiryukov
7 years ago

  • Component changed from General to Media
  • Focuses template added

#2 @wonderboymusic
7 years ago

  • Owner set to wonderboymusic
  • Resolution set to fixed
  • Status changed from new to closed

In 27908:

Fix a regression caused by [27622] in prepend_attachment() by passing all attachments that are not audio or video to the else clause.

Fixes #27634.

Note: See TracTickets for help on using tickets.