WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#27653 closed defect (bug) (duplicate)

"Warning: json_encode(): recursion detected in..." while updating or installing plugin/theme in 3.9 Beta 3

Reported by: hardeepasrani Owned by:
Milestone: Priority: normal
Severity: major Version: 3.9
Component: Plugins Keywords:
Focuses: administration Cc:

Description

I were testing some plugins in my test WordPress website (3.9 Beta 3)...and I saw following error, which I'm attaching to this ticket. This error appears when I try to Install or Update any WordPress plugin or theme in my 3.9 Beta 3 version.

Just after the error appeared twice, I decided to delete the database & setup my test site from the scratch. First I installed the 3.8 version, and it was working fine.

Then, I updated to 3.9 Beta 3 using the Beta Tester plugin, and the error is still appearing.

And I tried this with several plugins, and the error is appearing in all of them.

Attachments (1)

In 3.9 Beta 3.png (25.4 KB) - added by hardeepasrani 6 years ago.
Error while updating the plugin.

Download all attachments as: .zip

Change History (6)

@hardeepasrani
6 years ago

Error while updating the plugin.

#1 @hardeepasrani
6 years ago

  • Severity changed from normal to major

#2 @hardeepasrani
6 years ago

Line 261 & 405 in 3.9 Beta 3

$options['body']['update_stats'] = json_encode( $extra_stats );
$url = $http_url = 'http://api.wordpress.org/plugins/update-check/1.1/';

Line 261 & 405 in 3.8

$options['body']['update_stats'] = json_encode( $extra_stats );
$raw_response = wp_remote_post( $url, $options );
Last edited 6 years ago by hardeepasrani (previous) (diff)

#3 follow-up: @dd32
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #27633.

This has already been fixed, but that fix isn't in the current nightly. Should be right tomorrow.

#4 in reply to: ↑ 3 @hardeepasrani
6 years ago

Replying to dd32:

Duplicate of #27633.

This has already been fixed, but that fix isn't in the current nightly. Should be right tomorrow.

I'm glad that you guys already solved this prob, as I was worried because 16 April is really close :)

#5 @SergeyBiryukov
6 years ago

  • Focuses administration added; performance removed
Note: See TracTickets for help on using tickets.