WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#27662 closed defect (bug) (fixed)

Customizer: Multiple select tag does not show like a multiple select tag

Reported by: alexvorn2 Owned by: ocean90
Milestone: 3.9 Priority: normal
Severity: normal Version: 3.9
Component: Customize Keywords: has-patch
Focuses: Cc:

Description

It shows like a select tag...

We can add

height: auto;

so it will display nice

Attachments (1)

27662.patch (1.0 KB) - added by westonruter 5 years ago.
Prevent default customizer control field styles from applying to widget form fields. https://github.com/x-team/wordpress-develop/pull/8

Download all attachments as: .zip

Change History (5)

@westonruter
5 years ago

Prevent default customizer control field styles from applying to widget form fields. https://github.com/x-team/wordpress-develop/pull/8

#1 follow-up: @westonruter
5 years ago

  • Component changed from General to Appearance
  • Keywords has-patch added
  • Milestone changed from Awaiting Review to 3.9

I think the problem is that the default styles for fields in customizer controls are being applied to widget form fields.

#2 in reply to: ↑ 1 @ocean90
5 years ago

Replying to westonruter:

I think the problem is that the default styles for fields in customizer controls are being applied to widget form fields.

And that's fine I think.
I prefer height: auto;, we do the same for .wp-admin see trunk/src/wp-admin/css/forms.css#L292

#3 @ocean90
5 years ago

  • Summary changed from Widget Customizer: - multiple select tag from widgets do not show like a multiple select tag to Customizer: Multiple select tag does not show like a multiple select tag

Related: #10331

#4 @ocean90
5 years ago

  • Owner set to ocean90
  • Resolution set to fixed
  • Status changed from new to closed

In 27954:

Customizer: Add height: auto; for select[multiple].

fixes #27662.

Note: See TracTickets for help on using tickets.