WordPress.org

Make WordPress Core

Opened 5 years ago

Last modified 3 weeks ago

#27664 reopened enhancement

UX issues with Edit Image screen

Reported by: siobhan Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 3.9
Component: Media Keywords: needs-patch, bulk-reopened
Focuses: ui Cc:

Description

Now that it's possible to edit images from within the media modal, more people will hopefully use the functionality. I was playing with it, however, and there were some things that I found confusing and I think a regular user would be even more confused. Here's what they are:

1. Icons

https://i.cloudup.com/xbOIcQAZ2y.png

The feature I am most looking forward to having access to is being able to rotate images. I went to edit my image, and looked for the rotate button but found it to be greyed out, which was frustrating. Then I realised that I was looking at the Undo/Redo buttons. It wasn't clear to me that the rotate buttons were rotate buttons. The curved arrows of the undo/redo buttons look like they are for rotating.

A minor thing that could help would be positioning the Undo/Redo buttons on the left of the panel of buttons. I always conceptualise Undo/Redo as Forward/Back, and because Forward/Back buttons are always to the left hand side of a browser, this is where I expect to find them.

The flip buttons are also unclear. I clicked them thinking that they would grow the image horizontally or vertically, because that's what the image implies.

2. Crop

The series of actions to crop is:

  1. make selection
  2. click crop button

This is made more difficult by the fact that there's nothing in the UI to indicate that in order to crop you have to first make a selection. How is a user to know about this?

With all of the other actions, you click on the icons to make the action happen, but with cropping the action is reversed. It would be more intuitive if it was:

  1. selection action
  2. make selection
  3. click crop button

Another minor issue is that it's not obvious how to clear my selection if I decide not to crop. Because there is Cancel button underneath the image, I find my mouse automatically moving towards it.

https://i.cloudup.com/Xcndbg3Dcq.png

I'm sure that there are other ways that we could make image editing in WordPress a really great experience, but I think doing the following things could make a big improvement:

  • clearer icons for flip, undo/redo, rotate
  • reorder icons
  • change workflow for crop

Change History (11)

#1 @mikeschroder
5 years ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to Future Release

#2 @helen
5 years ago

Related on the API front: #21810

I think we need to go at this with a fresh eye, and not iterate on what's there. Iterating is cool, but sometimes a replacement is better, and I believe this to be one of those cases. lessbloat made an interesting set of wireframes back during 3.5 that I think have gotten lost in the sands of P2 comments: http://s.hyhs.me/UpcQ

#3 follow-up: @siobhan
5 years ago

I remember seeing those wireframes (once, a long long time ago). I definitely agree that it'd be worth looking at image editing with a fresh eye. Maybe this is something that could be worked in as a feature-plugin?

#4 @helen
5 years ago

Related: #11895

#5 in reply to: ↑ 3 @ericlewis
5 years ago

Replying to helen:

I think we need to go at this with a fresh eye, and not iterate on what's there. Iterating is cool, but sometimes a replacement is better, and I believe this to be one of those cases.

Hell yes. I have seen ticket after ticket about the Image Editor and it's quirky ways.

Replying to siobhan:

Maybe this is something that could be worked in as a feature-plugin?

Definitely.

#6 @ryan
4 years ago

Related #27901

#7 @chriscct7
3 years ago

@helen how would you like this ticket to proceed? Patch the issues mentioned or close in favor of a new system?

Last edited 3 years ago by chriscct7 (previous) (diff)

#8 follow-up: @helen
3 years ago

@chriscct7 Why does it need to be closed in favor of a new system? This seems like the right tracking/request ticket for a new system.

#9 in reply to: ↑ 8 @chriscct7
3 years ago

Replying to helen:

@chriscct7 Why does it need to be closed in favor of a new system? This seems like the right tracking/request ticket for a new system.

That seemed to be what you were proposing in comment:2. I must have misread that. My apologies!

#10 @iseulde
2 months ago

  • Milestone Future Release deleted
  • Resolution set to wontfix
  • Status changed from new to closed

This ticket has not seen any activity in over *two* years, so I'm closing it as "wontfix".

The ticket may lack decisiveness, may have become irrelevant, or may not have gathered enough interest.

If you think this ticket does deserve some attention again, feel free to reopen.

For bugs, it would be great if you could provide updated steps to reproduce against the latest version of WordPress (5.0.2 at the time of writing). Remember images or a video can be superior to explain a problem. At the very least, quickly test again to make sure the bug still exists.

If it’s an enhancement or feature, some extra motivation may help.

Thank you for your contributions to WordPress! <3

#11 @JeffPaul
3 weeks ago

  • Keywords bulk-reopened added
  • Milestone set to Awaiting Review
  • Resolution wontfix deleted
  • Status changed from closed to reopened

A decision was made to reopen tickets that were closed in the bulk edit that this ticket was affected by. This ticket is being placed back into the Awaiting Review milestone so it can be individually evaluated and verified to determine if it is still relevant/valid or reproducible.

Note: See TracTickets for help on using tickets.