WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#27672 closed enhancement (duplicate)

Add async argument to wp_register_script and wp_enqueue_script

Reported by: nickciske Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9
Component: Script Loader Keywords:
Focuses: javascript, performance Cc:

Description

Though defer is a mess and async isn't supported in older IE browsers, it seems like allowing async with a default of false gives plugin and theme authors the choice to use it if it's right for them... without hacky workarounds.

Some background:
http://www.html5rocks.com/en/tutorials/speed/script-loading/

Change History (1)

#1 @SergeyBiryukov
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #12009.

Note: See TracTickets for help on using tickets.