Make WordPress Core

Opened 10 years ago

Closed 10 years ago

#27707 closed defect (bug) (duplicate)

System uncheck Primary Location of Theme locations when add many menu items

Reported by: eric2011's profile Eric2011 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8.1
Component: Menus Keywords:
Focuses: Cc:

Description

I am working on a site which have many menu items, say about 100.
Current setting about Theme Locations is that the checkbox of "Primary Menu" is checked.

But System unchecked the checkbox after I added one more menu items, which mess up the navigation menu in front.

Attachments (3)

correct display before adding one more menu item.jpg (180.7 KB) - added by Eric2011 10 years ago.
Correct menu display before adding one more menu item
display error.jpg (227.5 KB) - added by Eric2011 10 years ago.
Error screenshot
setting.jpg (125.4 KB) - added by Eric2011 10 years ago.
affected setting. The "Primary Menu" is unchecked automatically after one new menu item added

Download all attachments as: .zip

Change History (9)

@Eric2011
10 years ago

Correct menu display before adding one more menu item

@Eric2011
10 years ago

Error screenshot

@Eric2011
10 years ago

affected setting. The "Primary Menu" is unchecked automatically after one new menu item added

#1 follow-up: @DrewAPicture
10 years ago

  • Keywords reporter-feedback added

Hi Eric,

Thanks for the report, though I can't seem to reproduce your issue on current trunk.

I wonder if you can give us a little more information about your issue. When you saved your menu, is it possible that the browser timed-out or froze in the midle of the saving process? Or did it simply save your changes and on the next viewing the location checkbox was unchecked?

#2 follow-up: @nacin
10 years ago

Sounds like #14134 to me.

#3 in reply to: ↑ 1 @Eric2011
10 years ago

Hi,

No time out or frozen in the middle of the saving process. And yes, on the next viewing the location checkbox was unchecked.

Replying to DrewAPicture:

Hi Eric,

Thanks for the report, though I can't seem to reproduce your issue on current trunk.

I wonder if you can give us a little more information about your issue. When you saved your menu, is it possible that the browser timed-out or froze in the midle of the saving process? Or did it simply save your changes and on the next viewing the location checkbox was unchecked?

#4 in reply to: ↑ 2 @Eric2011
10 years ago

Hi Nacin, Thanks.

I read #14134 before I create this ticket. It looks similar, but no one mention any setting changed in the process. So I open this ticket in case it is a new issue. Also wish somebody can confirm it if it is same issue to #14134

Replying to nacin:

Sounds like #14134 to me.

Last edited 10 years ago by Eric2011 (previous) (diff)

#5 @Eric2011
10 years ago

Can be solved by add below in .haccess

<IfModule mod_php.c>
php_value suhosin.post.max_vars = 5000
php_value suhosin.request.max_vars = 5000
</IfModule>

or add

<IfModule mod_php.c>
php_value suhosin.simulation 1
</IfModule>

#6 @DrewAPicture
10 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

And the magic words are "max_vars".

Closing as a duplicate of #14134.

Note: See TracTickets for help on using tickets.