WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#27709 closed defect (bug) (fixed)

Distraction-free writing UI and editor issues

Reported by: nacin Owned by: azaozz
Milestone: 3.9 Priority: low
Severity: minor Version: 3.9
Component: Editor Keywords:
Focuses: Cc:

Description

As pointed out toward the bottom of #27279. Some of these are regressions in 3.9, some in 3.8. Long list of them, we'll try to compile them here.

Attachments (7)

27709.patch (6.3 KB) - added by azaozz 5 years ago.
27709.1.patch (7.2 KB) - added by azaozz 5 years ago.
Screen Shot 2014-04-12 at 2.06.50 PM.png (33.0 KB) - added by nacin 5 years ago.
27709.2.patch (1.6 KB) - added by azaozz 5 years ago.
27709.3.patch (2.0 KB) - added by azaozz 5 years ago.
27709.diff (2.3 KB) - added by nacin 5 years ago.
27709.4.patch (2.6 KB) - added by azaozz 5 years ago.

Download all attachments as: .zip

Change History (17)

@azaozz
5 years ago

#1 @azaozz
5 years ago

In 27709.patch:

  • Move the word count to a fixed bar at the bottom. Instead of fading out, that bar slides down as it interferes with typing if hidden only by setting opacity: 0.
  • Fix responsive mode to 480px. Narrower screens will have a scroll bar.
  • Hide the Help button on screens < 480px, move the Save button to the right, make it bigger to match the others, and other responsive mode fixes.

This ticket was mentioned in IRC in #wordpress-dev by azaozz. View the logs.


5 years ago

@azaozz
5 years ago

#3 @azaozz
5 years ago

In 28043:

DFW:

  • Move the word count and "Just Write" to a fixed bar at the bottom.
  • Fix responsive mode to 480px. Narrower screens will have a scroll bar.
  • Hide the Help button on screens < 480px, move the Save button to the right, make it bigger to match the others, and other responsive mode fixes.

Fixes #26907, see #27709

#4 @nacin
5 years ago

There's a lot more listed in #27279 but [28043] is definitely a giant step in the right direction. We should summarize what's left and probably spin it into a new ticket for post-3.9.

#5 @nacin
5 years ago

  • Owner set to azaozz
  • Status changed from new to assigned

#6 @nacin
5 years ago

Regressions from 3.8:

  • The buttons in DFW don't ever have an active state. To reproduce, just add a link or make something bold.
  • The link button is never disabled. (Also as noticed in 3.8, the unlink button is disabled when nothing is selected and your cursor is not inside a link, which is also a ton less distracting. This is not limited to DFW, though.)
  • Due to the clever border tricks in [28043], a short amount of text results in a broken box. See screenshot above.
  • "Saved." (and "Save failed.") had a styling change. The font color changed a bit, and it is shown now to the right of the spinner. Due to the other bug noted below, it looks pretty bad when both "Saved." and a spinner is present, as the text moves the spinner around.

This is not a regression:

  • Clicking "Save" again should immediately hide "Saved." (or "Save failed.") when showing the spinner.

This ticket was mentioned in IRC in #wordpress-dev by nacin. View the logs.


5 years ago

@azaozz
5 years ago

#8 @azaozz
5 years ago

27709.2.patch moves the "Saved" and "Save Failed" back to the left of the spinner and extends the height of the border to the bottom. Also fixes a small regression with the .mce-fixed-width drop-downs in the editor toolbar (they have to be fixed width).

The changing state/disabling of buttons is quite more complex as they are outside of the TinyMCE UI. Will revisit in 4.0.

@azaozz
5 years ago

@nacin
5 years ago

@azaozz
5 years ago

#9 @azaozz
5 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 28116:

DFW:

  • Add background color and remove the top border from the status bar (at the bottom).
  • Fix spinner to always be next to the Save button.
  • Remove width: auto; from .mce-fixed-width.

Fixes #27709

#10 @nacin
5 years ago

[28116] fixes points 3, 4, and 5 from comment 6 above. Points 1 and 2 are essentially "won't fix" for the moment.

Note: See TracTickets for help on using tickets.