WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#27717 closed enhancement (duplicate)

Allow force plugin update (even if they are up to date).

Reported by: grosbouff Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8.1
Component: Plugins Keywords:
Focuses: Cc:

Description

Hi, Wordpress should allow updating plugins even if they are up to date.
I just was hacked and have to reinstall 30+ plugins so i'm sure they are clean.
But when selecting them and clicking "update", it says "plugin is up to date" for each of them.
There should be another option in the menu ("reinstall") so people like me can reinstall all plugins in a once. Or something allowing us to do it in special cases.

For what it worth (maybe it can help someone), I finally managed to do it by hacking class-wp-upgrader.php, around line ~555 : http://www.diffchecker.com/i41lfwfb

Change History (4)

#1 @ocean90
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #13953.

#2 @juliobox
7 years ago

Hello @grosbouff

i just made this for you : "Force Plugin Updates" plugin 1.0 (works for plugins, why not theme in 1.1)

https://wordpress.org/plugins/baw-force-plugin-updates/

See you

#3 @grosbouff
7 years ago

Thanks for your reply ! Didn't notice that !

#4 @grosbouff
7 years ago

(Still, it should be in core ! :))

Note: See TracTickets for help on using tickets.