WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 3 years ago

Last modified 3 years ago

#27721 closed defect (bug) (worksforme)

Row actions do not hide when right clicking the title

Reported by: jesin Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.7
Component: Administration Keywords: has-ux-feedback
Focuses: ui, javascript Cc:
PR Number:

Description

This bug affects admin pages that display row action links with the hover effect.

Steps to reproduce:

  1. Open any of the following - All Posts, All Pages, Library > Media, Comments, All Users, Dashboard comments section.
  2. Right-click the title links one below the other without clicking anywhere
  3. The row action links appear on all the right clicked rows and do not go away

Video: https://www.dropbox.com/s/dqwea177w5tizkz/common-js-bug.flv

Found this on IE11 and FF28, I have not checked on the earlier versions. Chrome is not affected.

Reason:

The /wp-admin/js/common.js file has this code that displays and hides action links.

On IE and Firefox the code inside setTimeout is not executed when focusin triggers on another row. This leaves the .visible class so the links do not hide.

Attachments (1)

27721.diff (877 bytes) - added by jesin 6 years ago.
Remove .visible class on all .row-actions elements except this when focusin event is triggered

Download all attachments as: .zip

Change History (10)

@jesin
6 years ago

Remove .visible class on all .row-actions elements except this when focusin event is triggered

#1 @DrewAPicture
6 years ago

  • Keywords has-patch ux-feedback added
  • Milestone changed from Awaiting Review to 4.0

Confirmed.

27721.diff fixes the issue as described.

Still seems weird to me that the row actions stick around when the row title is still focused but the mouse is no longer hovering. That might even be expected behavior for the focused row.

Last edited 6 years ago by DrewAPicture (previous) (diff)

#2 @nacin
6 years ago

The row actions are designed to appear for discoverability reasons when using keyboard navigation.

#3 @michalzuber
6 years ago

Patch worked for me, too.

Without patch: https://youtu.be/Xfpk9OKMlsY
With patch: https://youtu.be/juow5YFqKV8

After second video I upgraded FF to 31.0, issue still remained, but patch fixed it again.

#4 in reply to: ↑ description @PrathapMuruganandam
6 years ago

I too experience the same thing.

This ticket was mentioned in IRC in #wordpress-dev by DrewAPicture. View the logs.


5 years ago

#6 @DrewAPicture
5 years ago

  • Milestone changed from 4.0 to Future Release

There are definitely some performance concerns with this approach, especially as this would affect every row. Let's take another look in 4.1. Punting.

Related: #25408

#7 @chriscct7
4 years ago

  • Keywords needs-patch added; has-patch removed

#8 @steve1607
3 years ago

  • Keywords has-ux-feedback added; ux-feedback needs-patch removed
  • Resolution set to worksforme
  • Status changed from new to closed

Hi Jesin,
I tested it on my local instance and it works fine. Seems to be fixed.
https://youtu.be/mwqkLNZxp18

I tested it on Windows 10 with the newest versions of IE, Firefox and Chrome.

Do you still have this issue?

Many regards,
Steven

#9 @netweb
3 years ago

  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.