WordPress.org

Make WordPress Core

Opened 12 months ago

Closed 12 months ago

Last modified 10 months ago

#27744 closed defect (bug) (fixed)

Update TinyMCE to the current development version 4.0.21+

Reported by: azaozz Owned by: azaozz
Milestone: 3.9 Priority: normal
Severity: normal Version: 3.9
Component: TinyMCE Keywords: has-patch commit dev-reviewed
Focuses: Cc:

Description

There is a change in the current development version of TinyMCE that is needed in order to fix the adding of invalid/incorrect undo levels caused by updates inside wpviews: https://github.com/tinymce/tinymce/commit/60decfb411c75460793997bc21848682f963aacd

Attachments (1)

27744.patch (407.3 KB) - added by azaozz 12 months ago.

Download all attachments as: .zip

Change History (8)

comment:1 @azaozz12 months ago

The only other change is a fix for requireLangPack() in old plugins which is nice to have too: https://github.com/tinymce/tinymce/commit/dc4a1e6ee584d12cad5ebe06eb699bcc25ad1c24

Changelog since 4.0.21:

Added lastLevel to BeforeAddUndo event so it's easier to block undo level creation based on lastLevel data.
Fixed so old language packs get properly loaded when the new longer language code format is used.

Last edited 12 months ago by azaozz (previous) (diff)

@azaozz12 months ago

comment:2 @azaozz12 months ago

  • Keywords has-patch commit added

comment:3 @nacin12 months ago

  • Keywords dev-reviewed added

comment:4 @azaozz12 months ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In 28066:

Update TinyMCE to the current development version, 4.0.21.1. Fixes #27744

comment:5 @azaozz12 months ago

In 28138:

Update the TinyMCE tests to 4.0.21.1, see #27744

comment:6 follow-up: @programmin10 months ago

Any chance of updating this to 4.0.26 in the near future? Or would that be for next major release 4.0?

It fixes dozens of bugs in the current Tinymce 4.0.21 - see #28250

Thanks

Last edited 10 months ago by SergeyBiryukov (previous) (diff)

comment:7 in reply to: ↑ 6 @azaozz10 months ago

Replying to programmin:

Ha, coincidence? Been testing the update to 4.0.26 this afternoon :)

Note: See TracTickets for help on using tickets.