WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 years ago

#27752 closed feature request (duplicate)

Version recognition for translated installations

Reported by: icc97 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8.2
Component: Upgrade/Install Keywords:
Focuses: ui, administration Cc:

Description

If you have a translated version of WordPress and then install a later version of the default installation of WordPress on top then the WordPress dashboard doesn't think that you have updated.

This is a problem if you want to use the WordPress Skeleton (https://github.com/markjaquith/WordPress-Skeleton) from Mark Jaiquith. The WordPress github or indeed the subversion version of WordPress only has the default translation (US English).

Then the only way to get e.g. the dutch version is to set the define( 'WPLANG', 'nl_NL' ); and then include the translate files.

However then the WordPress dashboard (http://mysite.com/wp-admin/) doesn't think that you have the latest version of WordPress installed until you edit the wp-includes/version.php file to add the following line:

$wp_local_package = 'nl_NL';

Then of course you can't switch the tag using subversion or checkout a new tag using git as you've modified one of the files. So you have to revert the wp-includes/version.php file, switch to the latest tag and then re-modify the file again.

Change History (2)

#1 @SergeyBiryukov
7 years ago

  • Component changed from Administration to Upgrade/Install

Related: #23113, #27164.

#2 @ocean90
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #29528.

Note: See TracTickets for help on using tickets.