WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#27755 closed defect (bug) (fixed)

Headers in Customizer localization problems

Reported by: pavelevap Owned by:
Milestone: 3.9 Priority: high
Severity: minor Version: 3.9
Component: I18N Keywords: needs-patch
Focuses: ui Cc:

Description

There are several problems with localization of Headers section in Customizer:

1) Not enough space for 2 buttons (see screenshot).

2) Longer text for "Randomize..." button (see screenshot).

3) We also talk about "Suggested images" in Customizer but "Default images" in Custom Header page. It should be consistent...

Attachments (4)

Headers_localization_1.jpg (16.5 KB) - added by pavelevap 4 years ago.
Headers_localization_2.jpg (14.9 KB) - added by pavelevap 4 years ago.
27755-wrap-buttons.diff (1.4 KB) - added by ehg 4 years ago.
Headers_localization_3.jpg (10.8 KB) - added by pavelevap 4 years ago.

Download all attachments as: .zip

Change History (14)

#1 @pavelevap
4 years ago

4) Buttons "Randomize uploaded headers", "Randomize suggested headers" and "Reorder" (for widgets) should be visible only for more than 1 item (for header images) and more than zero item (for widgets)?

#2 @DrewAPicture
4 years ago

  • Focuses ui added
  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 3.9

#3 @nacin
4 years ago

  • Priority changed from normal to high
  • Severity changed from normal to minor

This ticket was mentioned in IRC in #wordpress-dev by nacin. View the logs.


4 years ago

#5 @ehg
4 years ago

attachment:27755-wrap-buttons.diff addresses points 1 and 2, by allowing the Hide/Add/Randomize buttons to expand if the text provided is too wide.

#6 follow-up: @pavelevap
4 years ago

And another one (point 5) - "Reorder" for widgets. It seems there should be enough space, but translated string is bellow... See attached screenshot.

#7 in reply to: ↑ 6 @ocean90
4 years ago

Replying to pavelevap:

And another one (point 5) - "Reorder" for widgets.

Can't reproduce this, which browser is it?

#8 @nacin
4 years ago

In 28086:

Custom Headers: Allow for longer strings.

props ehg.
see #27755.

#9 @nacin
4 years ago

  • Resolution set to fixed
  • Status changed from new to closed

I think "Suggested images" *may* be better, but it also might apply a bit more to WordPress.com than some random theme. I'm going to leave the discrepancy in place for 3.9 and we can figure it out one way or another in 4.0.

Closing as fixed. pavelevap, if you can reproduce any other issues (including widgets), can you open a fresh ticket?

#10 @pavelevap
4 years ago

ocean90: Chrome, still problem in latest trunk, see #27788.

nacin: OK, new tickets created #27786, #27787, #27788.

Note: See TracTickets for help on using tickets.