WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#27759 closed defect (bug) (fixed)

Disabled button color overrides color scheme colors on save

Reported by: ryelle Owned by: azaozz
Milestone: 3.9 Priority: normal
Severity: normal Version: 3.9
Component: Administration Keywords: has-patch commit dev-reviewed
Focuses: ui Cc:

Description

Noticed this while saving on my dev site, the disabled state of the button is always blue, no matter the color scheme in use.

Attachments (1)

27759.diff (522 bytes) - added by ryelle 6 years ago.

Download all attachments as: .zip

Change History (7)

@ryelle
6 years ago

#1 @ryelle
6 years ago

It looks like .disabled was added to buttons.css in [27038], but was not added to the button mixin. This is causing the default blue button to be used when saving/autosaving, no matter the color scheme selected. 27759.diff adds .disabled to the mixin, so the color scheme styles are used.

#2 follow-up: @nacin
6 years ago

  • Milestone changed from Awaiting Review to 3.9

I saw this on WP.org but could not reproduce on trunk. Does it make sense that this might not always happen somehow?

#3 in reply to: ↑ 2 @ryelle
6 years ago

Replying to nacin:

I saw this on WP.org but could not reproduce on trunk. Does it make sense that this might not always happen somehow?

I don't think so... I guess if the disabled class isn't added to the button, you wouldn't see this, but I think that's always added now. It's been consistent for me across all my trunk installs.

#4 @azaozz
6 years ago

  • Keywords has-patch commit added

Was able to reproduce in core /build, happens on the Edit Post screen. Caused by using input.disabled and a.disabled to both style the buttons and check status from JS.

The patch fixes it.

#5 @nacin
6 years ago

  • Keywords dev-reviewed added

Good to go.

#6 @azaozz
6 years ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In 28079:

Fix color of disabled buttons in non-default color schemes, props ryelle, fixes #27759

Note: See TracTickets for help on using tickets.