WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#27760 closed defect (bug) (fixed)

Quick Draft cannot be saved after a page refresh in Firefox

Reported by: SergeyBiryukov Owned by: SergeyBiryukov
Milestone: 4.0 Priority: normal
Severity: normal Version: 3.2
Component: Administration Keywords: has-patch commit
Focuses: javascript, administration Cc:

Description (last modified by SergeyBiryukov)

  1. On dashboard screen, create a Quick Draft and save it.
  2. Refresh the page.
  3. The title is empty, the content is populated with the latest draft, and "Save Draft" button is disabled, so you can't create a new draft.

Only happens in Firefox, could not reproduce in Chrome.

Appears to be introduced in [17743]. See also #17546.

Attachments (2)

27760.diff (1.3 KB) - added by morganestes 7 years ago.
Combined fixes of dashboard.js & dashboard.php
27760.2.diff (1.4 KB) - added by michalzuber 6 years ago.
Rewrite for current trunk

Download all attachments as: .zip

Change History (15)

#1 @SergeyBiryukov
7 years ago

  • Description modified (diff)

#2 @DrewAPicture
7 years ago

Reproduced on Firefox 28/Mac.

#3 @jeffr0
7 years ago

Reproduced on FireFox 28/Windows 7

@morganestes
7 years ago

Combined fixes of dashboard.js & dashboard.php

#4 @morganestes
7 years ago

  • Focuses javascript administration added
  • Keywords has-patch added

Turns out Firefox holds on to textarea values on a refresh, but disabling autocomplete fixes that.
I honestly still haven't figured out why the submit button remains disabled, but a quick fix is to brute force it to enabled when quickPressLoad() fires on page load.

I've only tested this in FF29 on OS X.

Last edited 7 years ago by morganestes (previous) (diff)

#5 @morganestes
7 years ago

  • Keywords needs-testing added

This ticket was mentioned in IRC in #wordpress-dev by morganestes. View the logs.


7 years ago

#7 @morganestes
6 years ago

  • Keywords needs-testing removed

#8 @SergeyBiryukov
6 years ago

  • Milestone changed from Awaiting Review to 4.0

#9 @michalzuber
6 years ago

Reproduced in Firefox 30/Mac.
With the patch it works.

@michalzuber
6 years ago

Rewrite for current trunk

This ticket was mentioned in IRC in #wordpress-dev by DrewAPicture. View the logs.


6 years ago

#11 @DrewAPicture
6 years ago

  • Keywords commit added

Patch solves the problem.

#12 @SergeyBiryukov
6 years ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from new to closed

In 29323:

QuickPress: Disable autocomplete for content, enable "Save Draft" button on load.

props morganestes, michalzuber.
fixes #27760.

#13 @helen
6 years ago

For future reference, while I think it's a little silly that browsers use the autocomplete attribute to not only toggle autocomplete but also whether or not the form holds onto a value when you do a soft refresh, in this case the form displaying a value after you had saved and it had presumably "disappeared" was a bug.

Note: See TracTickets for help on using tickets.