Make WordPress Core

Opened 10 years ago

Closed 10 years ago

#27768 closed defect (bug) (invalid)

Two Search Boxes on the themes.php page

Reported by: mikehansenme's profile MikeHansenMe Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Script Loader Keywords:
Focuses: Cc:

Description

I noticed today that I had 2 search boxes above my currently installed themes. When you start to type into either the url changes to localhost/undefined?s=whatever. I am seeing a few js errors as well

Error: Backbone.history has already been started
http://localhost/wp/trunk/build/wp-admin/load-scripts.php?c=0&load%5B%5D=jquery-core,jquery-migrate,utils,json2&ver=3.9-RC1
Line 3
TypeError: e is undefined
http://localhost/wp/trunk/build/wp-admin/load-scripts.php?c=0&load%5B%5D=hoverIntent,common,admin-bar,thickbox,underscore,backbone,wp-util,wp-backbone,theme,customize-base,customize-loader,svg-painter,&load%5B%5D=heartbeat,wp-auth-check&ver=3.9-RC1
Line 566

Note: this only happens for me when I have SCRIPT_DEBUG set to false. If it is set to true there is only 1 search box.

Attachments (3)

double-search.png (466.6 KB) - added by MikeHansenMe 10 years ago.
Double Search
double-search-undefined.png (342.9 KB) - added by MikeHansenMe 10 years ago.
Undefined in URL
2.diff (5.4 MB) - added by MikeHansenMe 10 years ago.
difference between 2 build dir

Change History (14)

@MikeHansenMe
10 years ago

Double Search

@MikeHansenMe
10 years ago

Undefined in URL

#1 @SergeyBiryukov
10 years ago

  • Milestone changed from Awaiting Review to 3.9

#2 @nacin
10 years ago

This sounds really bad, but I cannot reproduce.

#3 @MikeHansenMe
10 years ago

@nacin neither could @bpetty when I mentioned it to him. A few additional details: I am on revision 28079 and no plugins active. I dropped the db and set it up again, re-ran grunt. I was able to produce the problem on FF and Chrome. I will try to reproduce again elsewhere.

#4 @azaozz
10 years ago

Cannot reproduce either running from /build. Could that be some sort of race condition, how many themes do you have installed?

#5 @MikeHansenMe
10 years ago

I have the default themes plus 2 custom ones(not active).

#6 @nacin
10 years ago

What custom themes, Mike? Could you supply the style.css headers? It could be that the headers in them are causing errors? Can you see if JS is being loaded twice? Anything will help.

#7 @MikeHansenMe
10 years ago

I can reproduce it without those 2 themes as well. I got a diff between my build dir and @bpetty. Mine seems to be very different. I have a patch with the differences and you can see it is not normal and has changes in files that have not changed in a long time. I am fairly comfortable that this is specific to my setup and maybe my grunt tasks not completing or something like that.

Last edited 10 years ago by MikeHansenMe (previous) (diff)

@MikeHansenMe
10 years ago

difference between 2 build dir

#8 @ocean90
10 years ago

MikeHansenMe, please clean up your src dir.

There are a lot of wrong files like wp-admin/includes/plugin.php.orig, not deleted files like /wp-admin/images/lock-2x.png, files which doesn't have the correct content like wp-admin/css/wp-admin-rtl.css or files with wrong file name, like wp-admin/css/color-picker-rtl-rtl.css. The content of some min files is also corrupt.

#9 @SergeyBiryukov
10 years ago

  • Milestone changed from 3.9 to Awaiting Review

#10 @MikeHansenMe
10 years ago

  • Keywords close added

thanks @ocean90, cleaning up the src dir and rerunning grunt fixed the problem for me.

#11 @ocean90
10 years ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
  • Version trunk deleted
Note: See TracTickets for help on using tickets.