WordPress.org

Make WordPress Core

Opened 16 months ago

Closed 16 months ago

Last modified 16 months ago

#27779 closed defect (bug) (fixed)

RTL: Themes screen layout issue in Firefox

Reported by: SergeyBiryukov Owned by: nacin
Milestone: 3.9 Priority: normal
Severity: normal Version: 3.8
Component: Themes Keywords: has-patch commit
Focuses: ui, rtl, administration Cc:

Description

See the screenshot.

Attachments (3)

27779.png (835.6 KB) - added by SergeyBiryukov 16 months ago.
27779.patch (421 bytes) - added by SergeyBiryukov 16 months ago.
27779.2.patch (397 bytes) - added by SergeyBiryukov 16 months ago.

Download all attachments as: .zip

Change History (10)

@SergeyBiryukov16 months ago

@SergeyBiryukov16 months ago

comment:1 @ocean9016 months ago

Can't reproduce this in Firefox 28 on OS X.

@SergeyBiryukov16 months ago

comment:2 @SergeyBiryukov16 months ago

In case it's not clear from the screenshot and the patch, this is caused by .theme.active .theme-name being 1px higher than other .theme .theme-name elements. The "Active" word somehow triggers this difference.

The patch simply makes sure the elements have consistent height that doesn't interfere with floating blocks. .theme .theme-name would probably make more sense for that, see 27779.2.patch.

comment:3 @ocean9016 months ago

The patch simply makes sure the elements have consistent height

Okay, at least it doesn't break anything. But still can't see this on a clean install in FF 28 in OS X and Windows 8.1, with only $text_direction = 'rtl'; or Arabic language. Height is always 18px.

comment:4 @SergeyBiryukov16 months ago

Could not trigger this with Arabic language files either, only with he_IL.

comment:5 @ocean9016 months ago

  • Keywords commit added

Reproduced when I set the height of the active theme name to 19px.

comment:6 @nacin16 months ago

  • Owner set to nacin
  • Resolution set to fixed
  • Status changed from new to closed

In 28104:

Themes screen: Fix RTL layout issue in Firefox.

props SergeyBiryukov.
fixes #27779.

Note: See TracTickets for help on using tickets.