WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#27800 closed defect (bug) (invalid)

500 internal error with updated MySQL

Reported by: bou24 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8.1
Component: General Keywords:
Focuses: administration Cc:

Description

I'm getting the Internal 500 error on 3 different installs when server was upgraded to Mysql database version 5.5.35+wheezy1, running Apacke/2.2.9 (Debian) PHP/5.3.3.
However. Database client version: libmysql - 5.0.51a <--- could that be the cause?

When trying to access wp-admin -> permalinks i get internal 500 error. Neither server or wordpress logs says anything. .htaccess has been tested out a million times.

Clean install of earlier working 3.8.1 & 3.8.2 is now not anymore working since database update from the hosting company.

I've also tried a new browser and resetting my own browser settings just to rule those out.

Change History (2)

#1 @ocean90
8 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Please try the support forums for troubleshooting: ​​https://wordpress.org/support/

#2 @Denis-de-Bernardy
8 years ago

Itching to re-open this, because I'm pretty certain WP could do something about it.

Related: #27749

Here's a SO reference with a proper solution (aka use mysqlnd or recompile PHP):

http://stackoverflow.com/questions/10759334/headers-and-client-library-minor-version-mismatch

A potential WP-level fix is in those answers:

$err_level = error_reporting(0);  
$conn = mysql_connect('params');  
error_reporting($err_level); 

Note: See TracTickets for help on using tickets.