WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#27811 closed defect (bug) (duplicate)

SERVER_NAME is not defined when running wp-cron from real cron/shell

Reported by: szepe.viktor Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8.2
Component: Mail Keywords:
Focuses: Cc:

Description

Automatic updater sends an email but SERVER_NAME is not defined when wp-cron starts as a real Linux cron job.

Please uset get_option('site_url') to determine the hostname.

Change History (3)

#1 @dd32
6 years ago

This is caused by wp_mail() using a fallback address when a $from email is not specified.

I ran into this recently with another CLI WP script, but never looked into it.

#2 @szepe.viktor
6 years ago

PHP Notice:  Undefined index: SERVER_NAME in /var/www/noemi-salatabar/server/wp-includes/pluggable.php on line 328

#3 @SergeyBiryukov
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #25239.

Note: See TracTickets for help on using tickets.